Wenn du bereits mit dem Sverweis gearbeitet hast und die Grundlagen verstehst, bist du hier vollkommen richtig! Hier schauen wir uns den Sverweis ein wenig ausführlicher an, dazu nutzen wir eine kleine “Projektarbeit”. Viel Spaß!

Sverweis Funktion mit Datenblättern

Um sinnvoll mit der Funktion arbeiten zu können, benötigen wir ein paar Voraussetzungen:

  • Datenbestände und
  • evtl. ein Formular oder eine Maske um die Daten anzuzeigen.

Aus diesem Grunde ist unser Excel-Mappen Aufbau für das Beispiel innerhalb des Artikels der folgende: Wir erstellen einen Bereich (Arbeitsblatt) mit Kundendaten und eine Eingabemaske (Arbeitsblatt) mit Kriterien. Unterm Strich ist die Funktionsweise klar: Wir haben eine Kundendatenbank mit Excel und können uns beispielsweise die Daten eine Kundennummer anzeigen lassen.

Das funktioniert im Übrigen auch super mit Filter- und Sortierfunktionen. Dazu aber in einem anderen Artikel mehr!

Los geht’s: Excel Arbeitsmappe vorbereiten

Zunächst öffnen wir Excel und erstellen zwei Arbeitsblätter. Das erste nennen wir “Suchmaske und Ergebnis”, das andere “Datenbank”. Wo nun was steht, sollte klar sein: In das Arbeitsblatt ‘Suchmaske und Ergebnis‘ erstellen wir ein paar Eingabefelder für Kriterien und eine Tabelle die uns einen Kunden ausgibt. Besonderheiten:

  • Wir können die Tabelle rechts beispielsweise bedingt Formatieren (Zeile wird rot, wenn der Kunde gesperrt ist)
  • Wenn keine Kundennummer eingegeben ist, erscheint kein Fehler

Sverweis - Ausgabe und suchen

 

Für uns reicht im Arbeitsblatt “Datenbank” eine kleine Tabelle mit zwei, drei Daten. Ich habe es mal ein wenig ausführlicher gemacht, die Datei kann natürlich am Ende des Artikels heruntergeladen werden. Wichtig: Ich habe mich in der Kundendatenbank direkt für eine formatierte Tabelle entschieden, das erkennst du anhand der Dropdown-Menüs in der ersten Zeile. Somit können wir die einzelnen Spalten direkt mittels Namen ansprechen (zum Beispiel “Vorname”).

Sverweis Kundendaten

Die Sverweis Funktionen erstellen

Nun können wir uns einen Sverweis erstellen, im Grunde reicht ein ganz normaler vollkommen aus, allerdings zeige ich euch danach auch noch weitere Verbesserungen die das ganze Übersichtlicher machen. Wir beginnen mit der Funktion für die Eingabe der Kundennummer.

Das erste Arbeitsblatt ist nun geöffnet und wir Positionieren unseren Cursor in i4 und tippen die Formel:

=SVERWEIS(F5;Tabelle1;1;0)

Damit holen wir die Kundennummer aus der Datentabelle. Ganz wichtig ist hier der Spaltenindex, die letzte Zahl in der Formel. Wenn wir unsere Formel nun nach rechts kopieren muss der Index hochgezählt werden, ansonsten erscheint überall die Kundenummer. Auch sollten wir auf den Bezug achten, wenn die Formeln mal kopiert werden.

Hier nun die Formeln aus den anderen Zellen:

  • J4: =SVERWEIS(F5;Tabelle1;2;0)
  • K4: =SVERWEIS(F5;Tabelle1;3;0)
  • L4: =SVERWEIS(F5;Tabelle1;4;0)
  • M4 =SVERWEIS(F5;Tabelle1;5;0)
  • N4: =SVERWEIS(F5;Tabelle1;6;0)
  • O4: =SVERWEIS(F5;Tabelle1;7;0)

SVERWEIS Funktion Fehler “#NV” beheben

Vermutlich hast du es bei der Eingabe schon gemerkt: In allen Zellen erscheinen unschöne Fehlermeldungen.

Sverweis Fehler

Das liegt an der Tatsache, dass unser Eingabefeld in F5 leer ist. Demnach kann Excel nichts suchen. Schreiben wir nun eine Kundennummer in F5 die nicht existiert, gibt Excel auch keinen Kunden aus. Also kommt auch nichts, außer eine Fehleranzeige, wenn die Kundennummer nicht existiert.

Schreiben wir nun “675767” in F5 erscheint “Lisa Sturm” als Ergebnis. Jetzt müssen wir den Fehler in der Zelle beheben. Dazu nutzen wir die Funktion WENN und ISTLEER. Also müssen die Formeln nochmal geändert werden (Ja, das ist Absicht – Übung macht den Meister!).

Zunächst die WENN-Funktion mit der Prüfung, ob unser Eingabefeld in F5 leer ist:
= WENN ( ISTLEER(F5) ; “leer” ; “nicht leer” )

Anstelle der Angabe “nicht leer” kommt unsere Funktion und den Text “leer” löschen wir raus:

= WENN (ISTLEER(F5) ; “” ; SVERWEIS(C3;Tabelle1;1;0) )

Diese Formel übertragen wir nun passend in alle Zellen. Wenn “Kundennummer” nicht ausgefüllt ist, erscheint keine Fehlermeldung:

Sverweis Kundenausgabe ohne Fehler

 

 

SVERWEIS Funktion mehrere Felder prüfen

Natürlich kann das auch noch erweitert werden, dafür wird es allerdings einen eigenen Artikel geben!

Arbeitsdatei zum Artikel

Excel-Sverweis-Teil-2-Workfile.xlsx (4 Downloads)

Hat dir der Beitrag geholfen?